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1 Preface
The ILLKO Studio program is intended for support of inspections of electric equip-
ment. It allows transmitting the measured values from the selected measuring de-
vices for electric system inspections carried out by ILLKO, s.r.o. If REVEX de-
vice is referred to in the text below, it means REVEX 2051, REVEXprofi (II) and
REVEXmax devices collectively if not stated otherwise.

2 Program functions
• Management of the database of electric equipment with the Customer, Loca-

tion, Equipment and Measurement structure.

• Transmission of a list of equipment from a database in PC into REVEX and
MDtest devices (except for REVEX 2051).

• Transmission of the measured values from REVEX and MDtest devices into a
database in PC.

• The program contains FastReport R© generator of lists which allows:

– Creating, editing and printing of forms for inspection reports, lists of
equipment, etc.

– Exporting and printing of the results of inspections in PDF, HTML, JPG
and other formats.

• Management of a database of the inspecting technicians and measuring de-
vices.

• Import and export of the records on equipment in the CSV format for editing
in external applications of the spreadsheet type and further processing.

• Export of the records on equipment in the XML format for further processing.

• Export of the records on equipment in the format for ILLKO Studio View
browser.

c© 2024 ILLKO, s.r.o. www.illko.cz Page 5

www.illko.cz


ILLKO Studio - User’s Manual 3 Installation

3 Installation

3.1 Supported operating systems
• Windows 7, 8, 10, 11 (32-bit version, 64-bit version)

WARNING
Microsoft .NET Framework 4.8 interface has to be installed in the
computer.

Good user knowledge of work with PC in Windows supported operating systems is
necessary for work with the program and utilization of its functions. Knowledge of
work with spreadsheets (such as MS Excel or LibreOffice Calc) is beneficial.

3.2 System requirements
• A computer with minimum 1GB RAM.

• At least 50 MB of free space on the hard disk for the program + space for
data.

• A printer if you require output form printing.

• Recommended minimum monitor resolution: 1024x768 or 1280x720 pixels.

3.3 Program installation
• It is necessary to have the administrator’s rights for program installation, i.e.

to be logged in to a user’s account with computer administrator’s rights.

• Insert the installation CD in the CD-ROM drive or start the installation file
downloaded from www.illko.cz (skip following 2 steps).

• If automatic start of programs from CD is permitted, the initial menu from
which you can select program installation will be displayed.

• If automatic start of programs from CD is not permitted, start (e.g. using
Explorer) the Autorun.exe file located in the root directory of the installation
CD manually. The initial menu from which you can select program installation
will be displayed.
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• Follow the instructions of the installation wizard:

– Select the language of the application at first. Click on the Next button
after welcoming screen displaying.

– Select I accept the agreement after reading the licence conditions in
order to be able to continue installation. An inquiry for a destination path
of the installed program is displayed after clicking on the Next button. If
there is not any specific reason for a change of location, we recommend
that you accept the offered destination. The wizard will then inquire
about location of the program shortcuts in the Windows Start menu.
If you do not wish to create a shortcut in the Start menu, check the
Don’t create a Start Menu folder item. The wizard will offer you
the option to create a shortcut in the Windows work area in the next
screen. Select a field identification at your discretion. Installation is then
ready and can be started by clicking on the Install button.

WARNING
Program setting itself, forms and applied standards (VDE, EN, . . . )
is based on the selection of the language version of the installation
program.

3.4 Program uninstallation
• Quit the ILLKO Studio program.

• It is necessary to have the administrator’s rights for program uninstallation,
i.e. to be logged in to a user’s account with computer administrator’s rights.

• Select Start/Illko/ILLKO Studio/Uninstall or select the ILLKO Studio
program in the Start/Control panels/Uninstall a Program and select
Remove.

• Follow the instructions of the uninstallation wizard.

WARNING
The Documents/ILLKOStudio folder will be retained.

c© 2024 ILLKO, s.r.o. www.illko.cz Page 7

www.illko.cz


ILLKO Studio - User’s Manual 3 Installation

3.5 Program activation
The ILLKO Studio program is normally distributed in DEMO version. It is nec-
essary to enter an activation code manually or load it from a supported device
(REVEXmax, REVEXprofi II or MDtest) for obtaining a full version. The window
is displayed immediately after program start (Figure 1).

Figure 1: Program activation

3.6 Program data storage
The Documents/ILLKOStudio folder is created automatically after the first start
of the program. All files necessary for program running are stored in this folder.
The user can store files (databases) into any location on the computer hard disk, a
portable media, etc.
Meaning of individual folders:

• backups (backup files))
• logs (logging in files)
• reports (listings for print)
• settings (program setting, user’s notes etc.)

c© 2024 ILLKO, s.r.o. www.illko.cz Page 8

www.illko.cz


ILLKO Studio - User’s Manual 4 Program functions description

4 Program functions description
Note: The term Equipment in the program refers to a common electric appliance,
i.e. an appliance, tool, machine, welding machine, etc.

4.1 Data structure
The program allows management of theoretically unlimited number of records (the
actual number of records is restricted by the memory of the computer available and
partially also by computer performance).

The program database is presented in a form of a tree structure similar to the
structure of folders on computer hard disk. In order to allow easy arrangement of
the records on the carried out inspections, the following data structure has been
defined in the ILLKO Studio program:

4.1.1 Customer

The Customer is an organisation for which an inspection is carried out. Its record is
located on the highest (root) level of the root structure. Customer contact data are
saved in the record. The records on location (buildings, plants, . . . ) can be inserted
in the customer record only. The customer record is contained only once in the
database.

4.1.2 Location

The Location determines a place of physical occurrence of the inspected equipment.
Records of the inspected equipment are inserted in the Location. Any location can
be used also for inserting other locations (such as buildings, plants which contain
offices, workshops, . . . ). If records of equipment are inserted in a location, it is
not possible to insert a new location record simultaneously. The maximum location
record nesting position is five (i.e. the customer + 4 locations).

4.1.3 Equipment

The Equipment record bears information on the identification number, name, kind,
type, safety class, etc. (summarily identified as appliance heading). Records of the
carried out inspections (measurements) are saved in the equipment record. ID –
identification number is the most important part of the equipment heading. The
equipment identification number is the only link between a physical equipment and
its record in the database. The identification number is a chain of symbols repre-
sented by letters and numerals. A label with a bar code applied on the equipment
or a RFID transponder (chip) for wireless identification positioned under the equip-
ment plastic cover or attached to the appliance in a form of a pendant tag is an
ideal medium for ID.
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4.1.4 Measurement

Data (measured values) obtained using a measuring device during inspection to-
gether with the records of the inspector who has carried the inspection and of the
measuring device with which the inspection has been carried out are saved in a
measurement record. A record also contains the results of the inspection including
assessment and description of defects, date and time of the inspection carried out.
The measurement records are arranged on the basis of record date from the oldest
to newest one and thus constitutes the history of inspections carried out on the ap-
pliance in this way. A measurement record can be inserted in the equipment record
only.

4.2 Restrictions when creating database data structure
• A customer is contained only once in the database.

• A customer with at least one location must exist; otherwise, it is not possible
to insert pieces of equipment in the database.

• A location can be inserted in the Customer record or in another location only.

• If a location contains equipment, it is not possible to insert another location
in it.

• The appliance with a unique ID can be inserted only in the Location record.

4.3 Database files
Each database (or each customer) is saved in a separate file with ISD (ILLKO Studio
Data) extension. Only 1 file (database) can be opened in the program at a time.
However, multiple starts of the ILLKO Studio program are possible.
The files are opened and saved in a standard way.

4.4 LOG file
The contents of the logging in file can be displayed in the LOG file separate window
using the View->Show LOG file menu. A text listing of the program running is
included in this file:

• list of the deleted items
• list of the moved items
• error messages
• information on program running

4.5 Program appearance
The database structure is displayed in the left-hand part of the window (Figure 2).
Individual data items with respect to a selected database item (i.e. card) can be
defined in the right-hand part of the window. It is also possible to switch between
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individual windows using a keyboard: ENTER - access to the card, ESC - access
to the tree structure.

Figure 2: Program window

4.6 Icons

Customer
Location
Equipment (passed)

(passed - expired date of inspection, according to
program setting)
(failed)
(N/A - inspection has not been carried out)
(removed from registration - passed)
(removed from registration - failed)
(removed from registration - N/A)

Measurement (passed)
(failed)

Special (it does not contain nested records)
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4.7 Toolbars
4.7.1 Main toolbar

The main toolbar is always displayed (it cannot be deactivated). There are the basic
items used for control of the complete program in the main toolbar.

Figure 3: Main toolbar

4.7.2 Auxiliary toolbar

The auxiliary toolbar can be deactivated or activated using the View->Auxiliary
toolbar menu. There are the items used for operations with the Location, Equip-
ment and Measurement records in the auxiliary toolbar. The items in the auxiliary
toolbar are identical with those contained in the Edit menu or in a context menu
(clicking on the respective record with the right mouse button).

Figure 4: Auxiliary toolbar
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4.7.3 Toolbar setting - icon size

Size of the icons in the main and auxiliary toolbars can be adjusted using the
View->Small icons menu.

4.7.4 Toolbar setting - text descriptions

Displaying of the text descriptions of the main and auxiliary toolbars can be set
(individually) using the View->Labels - main toolbar menu or View->Labels
- auxiliary toolbar menu.

4.7.5 Toolbar positions

Both the main toolbar or the auxiliary toolbar can be positioned in any position in
either top or left-hand window part. The following combinations are possible:

• 1 panel in the top, 1 panel in the left
• 2 panels in the top in a single row one after the other
• 2 panels in the top in two rows one under the other
• 2 panels in the left, in a single column one under the other
• 2 panels in the left, in two columns one beside the other

The toolbars can be moved by mouse button clicking on the or symbol on
the left-hand or top edge of the toolbar and drawing in the demanded position. The
toolbars may not cover one another.
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5 Work with the program

5.1 Program updating
The program checks automatically at each start whether there is a new update of
the program at the website www.illko.cz (if Internet connection is available). This
information is displayed for the user in the top toolbar of the program (Figure 5).
The update itself is carried out manually - the user downloads the corresponding
installation program and carries performs update. Program setting remains retained.

Figure 5: Automatic check of new program version availability

5.2 Program setting
Select the Settings item in the main menu. It is possible to modify the parameters
as follows according to the tab selected (Figure 6):

• General

– language
– CSV file coding
– maximum length of the equipment name in the tree (the remaining sym-

bols are substituted with symbol ". . . ")
– newly created equipment ID prefix and length
– preset value for searching for expired inspections (number of days)
– automatic searching for expired inspections after program start

– highlighting of the expired inspections (different icon )

• Templates (pre-defined parameters for both new and existing appliances)

– creating a copy of the existing template
– the templates can also be imported/exported in the CSV format (indi-

vidual items are the same as for the equipment and group name and
template name are added)
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• Measurement sequences

– the selected parameter is moved from the Available methods list in the
Selected methods list using the key

– the selected parameter can be removed from the Selected methods list
using the key

– the order of the selected methods can be defined using the and
keys

• Supplier (it is used to enter the data necessary for form printing)

• Technician (a list of inspecting technicians - it is possible to insert also a
signature in the form of a picture such as JPG)

• Measuring devices

• Preset values (it can be used for quick selection of the following items):

– category
– equipment type
– method of connection
– measurement class
– measurement group

• Display mode (it is possible to select which parameters should be displayed
in the Filter window and in the Measurement tab when selecting the "Own
selection" item)

• Import/Export (it is used to save and read the program setting)

WARNING

• If setting is changed, it is not necessary to restart the program
(this does not apply to a language change and when importing a
setting from a file).

• If a collision occurs (e.g. when serial numbers are identical for
more measuring device), the change is not carried out and the
user is notified with a message of error occurrence.
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Figure 6: ILLKO Studio program setting (user profile)

5.3 Automatic notification of database saving
The function can be activated by selection of a time interval in the top toolbar of
the program. If data is changed, the option to save the program is offered to the
user according to the interval selected. The function can be deactivated by selecting
the "- - -" value.

5.4 Creating of backup
A backup is created automatically at each database saving in a file (Documents/
ILLKOStudio/backups folder). The backup name consists of the initial file name
and date and time of saving. The user can restore the data from the backup using
the File->Restore from backup main menu.
The size of the folder Documents/ILLKOStudio/backups is checked at each start;
if 500 MB is exceeded, the user can display the directory and delete the unnecessary
files.

5.5 Data import from previous programs
The program allows data importing from the REVIZEprofi V1.6 and V2.0 programs.

The imported data opens in a new database. It is necessary to select a customer
before import itself (only 1 customer can be present in the ILLKO Studio program
database). After data import completing, the user can save the data in a file and
import another customer from the same database.
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5.6 Data import from CSV file
A CSV file can be imported into:

• an empty database
• an existing database

It is checked during import whether the appliance is present in the database. If it
is the case, appliance parameters are not changed and only the measurement
with a different date of the inspection carried out is added. If the equipment
is not present in the database (an empty database or a new piece of equipment), the
equipment is created and a measurement is assigned to it simultaneously (if it has
been defined). The new equipment is saved in the defined location. If any appliance
location is not defined in the CSV file, pieces of equipment are created automatically
in the location called _Unassigned.

WARNING
Automatic moving of the existing pieces of equipment in another loca-
tion can never take place!

Note: If an error occurs during import, this fact is indicated together with the num-
ber of the line on which the error occurred. A window with results (new/existing
equipments, new/existing measurements) is displayed after import completing. The
results are recorded also in the LOG file.

5.7 Data export in CSV and XML files
The user can export the files in either CSV or XML format. CSV file data is coded
according to a definition in the setting. Individual data items are separated with ;
and are defined with the quotation marks ".
Only the last measurement or all measurements can be exported in the CSV and
XML files.

WARNING
Complete information on appliances and measurements (ex-
cept for supplier’s information) is exported in the CSV and XML
files. It results from the above mentioned that any loss of information
does not take place when exporting data in CSV, editing it in any
spreadsheet and consequent importing in the ILLKO Studio program.

5.8 Data export for ILLKO Studio View browser
The complete database with the currently set supplier can be exported for the
ILLKO Studio View browser in which the user can view, search for or print inspection
reports for electric appliances without the possibility to change individual
items. The file is protected against potential misuse (it is not possible to create a
full-value database from it).
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5.9 Item (record) creating
5.9.1 Customer

An item can neither be created nor deleted. It is present only once within the
complete database.

5.9.2 Location

• using the key shortcut Ctrl+L (location)

• by clicking on the icon in the auxiliary toolbar

• using a context menu (by right-hand mouse button clicking on the selected
item) and selecting Add location

• using the main menu Edit->Add location

5.9.3 Equipment

• using the key shortcut Ctrl+E (equipment)

• by clicking on the icon in the auxiliary toolbar

• using a context menu (by right-hand mouse button clicking on the selected
item) and selecting Add equipment

• using the main menu Edit->Add equipment

Equipment can also be created by copying another equipment:

• using the key shortcuts Ctrl+C and Ctrl+V

• by clicking on the and icons in the auxiliary toolbar

• using a context menu (by right-hand mouse button clicking on the selected
item) and selecting Copy equipment/measurement and Paste equipment/
measurement

• using the main menu Edit->Copy equipment/measurement and Edit->
Paste equipment/measurement

When creating a new piece of equipment, a list of templates (Figure 7) which should
be applied to the newly created piece of equipment is offered automatically (this
does not apply to equipment copying). Templates can be assigned to categories (if
any category is specified, the template is displayed in the _Unassigned category.
Window size can be changed. If the list of templates is not available or if you click
on the Cancel button, empty equipment is created.
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Figure 7: List of templates

5.9.4 Measurement

• using the key shortcut Ctrl+M (measurement)

• by clicking on the icon in the auxiliary toolbar

• using a context menu (by right-hand mouse button clicking on the selected
item) and selecting Add measurement

• using the main menu Edit->Add measurement

Measurement can also be created by copying another measurement:

• using the key shortcuts Ctrl+C and Ctrl+V

• by clicking on the and icons in the auxiliary toolbar

• using a context menu (by right-hand mouse button clicking on the selected
item) and selecting Copy equipment/measurement and Paste equipment/
measurement

• using the main menu Edit->Copy equipment/measurement and Edit->
Paste equipment/measurement

WARNING
Information on the measuring device or other measuring devices and
the inspector are deleted when copying a measurement. Measurement
date is inserted according to PC setting.
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5.10 Item editing
All items (Customer, Location, Equipment and Measurement) can be edited. Saving
can be carried out by depressing the Save changes button or the F12 key. When
selecting (marking) another item in the tree, a window with inquiry will be displayed
in the case of unsaved changes. The user can either save or discard the changes.

5.11 Item deleting
The Location, Equipment and Measurement can be deleted (including the
nested records):

• by depressing the Delete key

• by clicking on the icon in the auxiliary toolbar

• using a context menu (by right-hand mouse button clicking on the selected
item) and selecting Delete selected items

• using the main menu Edit->Delete selected items

5.12 Item movement
The Location and Equipment can be moved (including the nested records) in
another position by simple mouse dragging. Other possibilities of movement:

• using the key shortcuts Ctrl+X and Ctrl+W

• by clicking on the and icons in the auxiliary toolbar

• using a context menu (by right-hand mouse button clicking on the selected
item) and selecting Select items for moving a Move selected items

• using the main menu Edit->Select items for moving a Edit->Move se-
lected items

The program checks automatically whether the movement is possible (another nested
location together with equipment may not be present in the location, etc.). It
is necessary to confirm the movement in order to avoid accidental (unintentional)
changes.
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5.13 Apply template
It is possible to change the parameters of the selected pieces of equipment either
individually or generally in the program:

• using the key shortcut Ctrl+T (template)

• by clicking on the icon in the auxiliary toolbar

• using a context menu (by right-hand mouse button clicking on the selected
item) and selecting Apply template to equipment

• using the main menu Edit->Apply template to equipment

When applying a template, equipment ID and its serial and inventory number will
be retained. All the other parameters will be changed according to the template
selected.

5.14 Apply sequence
It is possible to assign a measuring sequence for the selected pieces of equipment
either individually or generally in the program:

• using the key shortcut Ctrl+S (sequence)

• by clicking on the icon in the auxiliary toolbar

• using a context menu (by right-hand mouse button clicking on the selected
item) and selecting Apply sequence to equipment

• using the main menu Edit->Apply sequence to equipment

5.15 Appliance search
It is possible to search for a piece of equipment simply according to a unique ID,
inventory number, serial number or sorting key in the program main window. It is
possible to enter either the complete chain or a chain with substitutional symbols:
the "_" symbol substitutes 1 symbol while the "%" symbol substitutes any number of
symbols.

5.16 Filter & equipment multiple modifications
Select a customer or only a location in the Filter window at first (it is possible to
select using either CTRL key or SHIFT key even from more locations). Other nested
locations are also included in the selection. If it is necessary to search for pieces
of equipment according to a certain criterion, select the Use filter option and
enter one or more criteria. It is possible to display the equipment by depressing the
Load and show equipment button. The resulting list can be arranged in columns
alphabetically.
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Pieces of equipment can be selected using the CTRL or SHIFT keys (selection of all
the listed pieces of equipment can be carried out using CTRL+A). The following
operations can be carried out with this equipment:

• mass changes of parameters for the selected equipment
• printing
• sending equipment into a measuring device
• deleting

A mass modification of a parameter of equipments (Figure 8) can be carried out by
enabling the given parameter ( selection) and entering a value (the other data will
be retained, i.e. the original data will remain). When reading a window (Figure 8),
the texts (data) identical for all the selected pieces of equipment will be displayed.
The different data is not displayed (blank text).

Note: All items are only "pre-filled" at template applying. For actual application of
the changes, it is necessary to enable the required items using .

Figure 8: Mass editing of equipment parameters
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5.17 Filter & measurement mass modifications
The start of the procedure is identical with that in Section 5.16. It is necessary to
switch the Measurements for selected equipment tab after selection of equip-
ment from the table. It is again possible to make the selection more specific using
a filter. The selected measurements can be modified, printed or deleted.

A mass modification of a parameter can be carried out using the same method as
that described in Section 5.16.

5.18 Equipment name automatic proposal
When editing the Name in the Equipment tab or in Filter (mass modifications), a
list of already used names is offered to the user after entering at least 3 symbols
(Figure 9).

Figure 9: Equipment name automatic proposal

5.19 Searching for expired inspections
The program allows searching for expired inspections. Select the date from which
searching should be made in the Expired inspections window (Figure 10) (when
opening the window, the date is set automatically according to the preset number
of days from the current date and searching is made).
The user also has the option to search for expired inspections from more databases
(files) saved in the same folder. The results can be saved in a CSV file.

WARNING
When selecting more databases (files), the currently open database is
not searched for - the database (or data) is present in a temporary
folder of the Windows system and it may not correspond to the data
saved in the file which has been used (read) in the program.
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Figure 10: Searching for expired inspections

5.20 Report printing
The results can be printed using both pre-defined and customized reports in the
FastReport R© environment. Printing can be carried out by selecting the customer,
location, equipment or measurements in the main window and depressing the Print
button. It is also possible to print from the Filter window after selecting the pieces
of equipment and measuring on the basis of the required parameters. In the Print
window, it is possible to carry out:

• report selecting
• report renaming, copying or deleting
• report reading from a file
• report saving in a file
• report editing
• print customized setting

– to print inspector’s signature
– to sort by location (standard arrangement is sorted by equipment ID)
– to print all measurements (only the last measurement is printed in stan-

dard configuration)
– to print including the equipment removed from registration
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5.21 Report modification
The report consists of the individual objects in which it is possible to change text,
size, font, border, etc. It is also possible to copy and move these objects.

A report modification can be carried out the following steps:

• select the suitable report and make copy by depressing the Copy button
• open the Editor by depressing the Run editor button
• left-hand mouse button clicking (2x) on the selected object
• change the text or select the database field using the Data Sources in the

right part of the window

Note: A plain text is inserted into the text field directly, database field is inserted
into the text field with the brackets "[ ]". Text field allows the combination of
plain text and database fields.

WARNING
The reports are stored in separate files with FRX extension in the
Documents/ILLKOStudio/reports folder.

Report editing is intended for the more experienced users. The infor-
mation and instructions for operation of the Fast-Report R© environ-
ment are available at www.fast-report.com

5.22 Information
The program contains a document in which the abbreviations of the measured pa-
rameters used are listed. This document is in the PDF format and can be displayed
by selecting Help->Information in the main menu or using the button in Settings
window.

5.23 User’s notes in the program
The user can create his/her own notes. The window with comments can be displayed
by selecting Help->User’s note in the main menu. The text can be modified using
the Edit button. The modifications made can be either discarded or saved.
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6 Communication with measuring device
Communication with measuring device differs in dependence on the measuring device
type:

• REVEX 2051 - data downloading only
• REVEXprofi (II) - data sending in the device as well as data downloading
• REVEXmax - data sending in the device as well as data downloading
• MDtest - data sending in the device as well as data downloading

WARNING
The ILLKO Studio program does not recognize location at communi-
cation with the REVEXprofi (II) device; i.e. the recorded equipment is
displayed in the initial location in the device. When downloading data
and consequent merging, no automatic movement of equipment
between locations is carried out. New pieces of equipment are saved in
the location with the identification _Unassigned.

6.1 Data sending in a device
Currently selected locations or pieces of equipment can be chosen by depressing the
Send data or using the F6 key and a window for data sending is displayed then
(Figure 11). There is a number of selected pieces of equipment displayed in the
bottom part. A measuring device type and a communication port (it depends upon
device type) is to be selected then. The data is sent in the device by depressing the
Send button or F5 key. The name of the measuring device including its serial number
and firmware is displayed in the bottom part of the window during transmission. If
an error occurs during data transmission, a message is displayed.

Figure 11: Data sending in a device
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WARNING

• If it is not possible to establish communication with the measur-
ing device, terminate all the programs communicating with the
measuring device (such as REVIZEprofi 2 program) or check the
installed driver. If the program persists, use another communi-
cation protocol (it depends upon device type).

• Inspector selection is carried out only at data downloading from
the device.

• Information on the sequences for a specific piece of equipment
is transmitted in the device; the sequences listed in the program
setting (user profile) are also transmitted.

6.2 Data downloading from device
The window for data reception is displayed by depressing the Download data button
or F7 key (Figure 12). A measuring device type and a communication port (it
depends upon device type) is to be selected then. The data is downloaded from
the device by depressing the Download data button or F5 key. The name of the
device including its serial number and firmware is displayed in the bottom part of the
window during transmission. The number of pieces of equipment read is displayed
in the bottom part after transmission completing.
If an error occurs during data transmission, a message is displayed.

Figure 12: Data downloading from device
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It is possible to carry out the following operations with the downloaded data:

• to delete the marked pieces of equipment

• to change total result, visual check, functional test and measurement for the
marked pieces of equipment generally

• to change total result, visual check, functional test and measurement, equip-
ment ID, measurement date/time and comment with respect to measurement
for a specific appliance

• to assign other measuring devices and fixtures for all measurements

The measuring device used is paired automatically with the data obtained from the
program setting (user profile).
The downloaded data can be merged with the data in the current database imme-
diately or such data can be exported in a CSV file.

WARNING

• Merging of the downloaded data with the data in the current
database takes place on the basis of the same principle as CSV
file import - the user is notified of the modifications carried out
(number of new and existing records) after merging (import)
completing. The information is recorded also in the LOG file.

• When downloading data from the REVEX 2051 device, a window
is displayed during transmission where it is possible to select a
specific measuring device and select deleting of the initial "0".

• If only one inspector is listed in the program setting, it is selected
automatically. If this is not the case, it is necessary to select
the inspector manually.
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List of items
(used in XML, CSV files and lists for printing)

Customer & Supplier
Company company name
Street street
City town or city
PostCode postal code
Country country or state
Identifier company identification number
VatId VAT identification number
Name first name
Surname surname
Phone telephone number
Fax fax number
Email e-mail address
Note note

Equipment
IdText1 ID
Name equipment name
SerialNumber serial number
Inventory inventory number
Category category
EquipType equipment type
Connection method of connection
MeasClass measurement class
MeasGroup measurement group
CableLen cable length
LastRev last inspection date
NextRev next inspection date
Interval interval between inspections [months]
AutoRev automatic assessment of the term of the next inspection
Result inspection result
Tree1..41 location (max. 4 levels)
TreeTotal total location (only in lists for printing)
Note note
SortingKey sorting key
CustName1..5 customer items - name (max. 5 items)
CustValue1..5 customer items - value (max. 5 items)
Archive removed from registration
Sequence measuring method (names separated with ",")
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Measurement
Date1 inspection date
Time inspection time
ResultTotal1 total inspection result
ResultVisual1 visual check
ResultFunct1 functional test
ResultMeas1 measurement result

Values of the "result" items:
- Failed
- Passed
- N/A

TechName inspecting technician name
TechSurname inspecting technician surname
TechLicence inspecting technician licence
TechPhone inspecting technician phone
TechEmail inspecting technician e-mail address
DevName measuring device name
DevSerialNumber measuring device serial number
DevCalibration measuring device calibration number
DevValidity measuring device calibration validity
DevNext other measuring devices and fixtures
SortingKey sorting key (in CSV, XML file: MeasSortingKey)
Note note (in CSV, XML file: MeasNote)
...measured

param. abbrev. mentioned directly in program - Information button

Templates
Group template group - optional data item
Id template name
Name equipment name
Category category
EquipType equipment type
Connection method of connection
MeasClass measurement class
MeasGroup measurement group
Interval interval between inspections [months]
CableLen cable length
SortingKey sorting key
Note note
CustName1..5 customer items - name (max. 5 items)
CustValue1..5 customer items - value (max. 5 items)
AutoRev automatic assessment of the term of the next inspection
Sequence measuring method (names separated with ",")

1Columns which must always be contained in the imported CSV file. The values of items
(except for IDtext) can also be blank.
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Licence
c© 2012-2024 ILLKO, s.r.o.
Windows is a registered trademark of the Microsoft company.
All the other mentioned trademarks and copyrights are a property of their respective
owners.
Distribution of the versions of this document modified in a substantial way without
written consent of the owner of copyright is forbidden.
The documentation is provided in the status "as it is" and all express or implied con-
ditions, statements and guarantees including all implied guarantees of merchantabil-
ity, suitability for a specific purpose or non-infringement of foreign rights are ex-
cluded except for the scope within which such refusals of guarantees are considered
to be legally ineffective.

Licence agreement
This is the licence agreement between you, end user of the computer program, and ILLKO,
s.r.o. (hereinafter "ILLKO" or "ILLKO company").).
Please read this licence agreement carefully!
If you do not agree with the terms and conditions of this licence agreement, stop using this
program immediately! You have the right for reimbursement of the paid licence fee within
15 days from the date of purchase of the given program version if you return all physical
parts of the product package and destroy all the copies of the given program version made
so far or uninstall already installed program.

1. Licence provision. Through this licence agreement, the ILLKO company grants
you non-exclusive, non-transferable right to use a copy of the computer program provided
by the ILLKO company if you comply with the terms and conditions defined in this
agreement. Your licence applies also to the software incorporated in the ILLKO resulting
program as a component. Integrated components are and remain the property of the third
parties.

2. Copyright. The computer program which is the subject of this licence agreement is
and remains the property of the ILLKO company. The computer program is a subject of
copyright and as such it is fully subjected to its protection. This does not affect the rights
of the third parties the components of which are used in the licensed program.

3. Limitation of use. You may not use the program in a way which could damage or
disturb the copyright of the manufacturer in any way. It is above all forbidden to make
copies of the program (including one copy intended solely for the purpose of archiving and
backup); you also may not reproduce, modify, alter, decompile, translate from machine
code, analyse reversely the program or to make related works from it by its processing.
All rights which are not expressly granted are reserved. Any copies of the program which
may be made by you on the basis of this agreement must contain complete copyright and
other statements which are attached to the program original copy.

4. Transferability limitation. This licence is granted you personally and for that reason,
it does not allow you to resell, lend, submit, hire any copy of the program or to transfer
it on any person in any way. Any transfer contrary to the above mentioned provision is
invalid and represents a cause for termination of validity of your licence.

5. Number of installations. By purchasing one licence of the program, you obtain the
right for installation and use of the program in two computers provided that the copy of
the program is never loaded in the RAM memories of both computers simultaneously and
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also provided that both the computers are operated by you.
6. Limited guarantee. ILLKO guarantees the program in the substantial features

to comply with the user documentation for at least 15 days from the date of purchase
of the given program version. ILLKO does not guarantee the program to run without
interruptions or to be free of errors. The above mentioned guarantee is the only guarantee
provided instead of all other guarantees, expressed or implied including implied guarantees
of merchantability and suitability for specific purposes.

7. Guarantee of reimbursement without specifying any reason. If the program does
not fulfil your demands laid on it or is unsuitable for you for any reason, you have the
possibility, without giving any reasons, to return it in the ILLKO company within 15 days
from its purchase. In such event, you are entitled to reimbursement of the paid licence
fee provided that all copies of the program saved on your hard disk or archived otherwise
will be destroyed, the program uninstalled or the original package will be returned. If the
licence is cancelled for any reason, automatic blocking of the program may occur in the
case of its continued using.

8. Limitation of liability. Neither the ILLKO company nor its dealers and suppliers
bear any liability for any consequent, accidental or special damages including lost profit,
interruption of business or loss of data resulting from use or inability to use this program
even if the ILLKO company is notified of the possibility of occurrence of such damages.
Liability for potential damage caused by use or inability to use this program is governed,
with your consent given by this agreement, by the Commercial Code of the Czech Republic.
For the event of occurrence of any damage for which the ILLKO company, its dealers
and suppliers would bear responsibility so that the ILLKO company would be liable for
compensation as well as for the event when jurisdiction of any country would not allow to
exclude or to limit compensation for the damage, a contractual penalty has been agreed
upon in the amount of the licence fee paid by you for the product on the basis of which
the damage has been caused and such contractual penalty includes in it already a lump
compensation for such potential damage. The program delivered is not intended to be
deployed in applications with high risk, especially where program failure could directly
endanger life or cause considerable material damage. Such applications include e.g. the
operating part of nuclear power plants, weapon systems, equipment intended for direct
support of vital functions of persons, etc.

9. Program updating. In order to maintain correct functionality of the program, the
manufacturer or its business partners may issue program updates available through web-
sites or on memory media (such as CD-ROM). These updates improve program properties
and eliminate potential errors. If you download any program update, you bear all risks
with respect to damage of the program during transmission and downloading.

10. Governing law, arbitration clause. This agreement is governed by the law of the
Czech Republic with exclusion of any standards in collision. All disputes which could arise
from this agreement or in connection herewith will be decided, with exclusion of authority
of civil courts, with final validity in arbitration proceeding before the Arbitration Court
at the Chamber of Commerce of the Czech Republic and the Chamber of Agriculture of
the Czech Republic in Prague in accordance with its Rules by three arbitrators appointed
in accordance with these Rules. The parties undertake to fulfil all the duties imposed on
them in the arbitration sentence within the periods specified in it.
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